$re = '/(?|(123 USD)|(?=(USD 123)))/m';
$str = 'USD 123 USD';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);