const regex = /(?:foo|\G(?!^))(\d+).*?(?=(\w+))\w+(?=\1\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:foo|\\G(?!^))(\\d+).*?(?=(\\w+))\\w+(?=\\1\\b)', 'gm')
const str = `38 ay bee ceefooh deefoo38 ee 37 ef gee38 aitch 38 eye19 jay38 kay 99 el88 em38 en 29 ou38 38 pee 12 q38 arr 999 es38ss 555`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}