$re = '/(?:foo|\G(?!^))(\d+).*?(?=(\w+))\w+(?=\1\b)/m';
$str = '38 ay bee ceefooh deefoo38 ee 37 ef gee38 aitch 38 eye19 jay38 kay 99 el88 em38 en 29 ou38 38 pee 12 q38 arr 999 es38ss 555';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);