const regex = /\.[a-z_-][\w-]*(?=[^{}]*{[^{}]*})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.[a-z_-][\\w-]*(?=[^{}]*{[^{}]*})', 'g')
const str = `.class-a, #id-a, .class-b:hover { text-align: center; }
table.simple{background:#fff;}.bg-white{background:#fff;}
/*# sourceMappingURL=style.css.map */
/*
Example comment file.css
*/`;
const subst = `.a`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);