using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?x)
\b(?:
(?<day>[0-9]{1,2})[-_.]
(?<month>[0-9]{1,2})[-_.]
(?<year>[0-9]{4})
|
(?<year>[0-9]{4})[-_.]
(?<month>[0-9]{1,2})[-_.]
(?<day>[0-9]{1,2})
)\b";
string input = @"Youghusband Friends 2012-12-14 003.jpg
Youghusband Friends 2012.12.14 003.jpg
Youghusband Friends 2012_12_14 003.jpg
Youghusband Friends 12-14-2012 003.jpg
Youghusband Friends 12.14.2012 003.jpg
Youghusband Friends 12_14_2012 003.jpg";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}