re = /^(?i)(?!.*foo.*$).+/m
str = 'Text with foo here
foo Text
More foo
foo
Match this line
this seems to work
as does this with foo
foofff
ffffoO
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end