using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https:\/\/[\w-]*\.?zoom.us\/j\/([\d\w?=-]+)\?pwd=([\d\w?=-]+)";
string input = @"https://yandex.zoom.us/my/somename
https://uni-hamburg.zoom.us/j/71047121108
https://zoom.us/j/9691388953?pwd=U2VnRTg5VDdzRW0xSHNlZXM4UFlKQT09
https://mvideoeldorado-ru.zoom.us/j/12317847439?pwd=UHM1bHdPZ2hPdmVrZlNtV2RMdXc5UT09
https://yandex.zoom.us/j/12303260396
https://us06web.zoom.us/j/12365249269?pwd=SFF3aTNyZ1dPSVRkcVN0aTV0SmxuQT09
https://us05web.zoom.us/j/88260874709?pwd=bFNuL1ZmeGVYb0h3c0NoTGVPOS9aUT09
https://leroymerlin.zoom.us/j/91567406167?pwd=aWRud1JzVllIQ3Q1TTk0QjZLTkltZz09";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}