$re = '/width="(\d+)(px)?"/u';
$str = '│Арт │ Имя │Количество │Зак.цена │
├──────────┼───────────────────────────────────────────────┼───────┼─────────┤
<img width="30" height="auto" src="/descriptions/models/michelin/PilotSport5/40.jpg" class="pic_left">
<img width="30px" height="auto" src="/descriptions/models/michelin/PilotSport5/40.jpg" class="pic_left">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);