re = /width="(\d+)(px)?"/
str = '│Арт │ Имя │Количество │Зак.цена │
├──────────┼──────────────────────────────────────────── ───┼───────┼─────────┤
<img width="30" height="auto" src="/descriptions/models/michelin/PilotSport5/40.jpg" class="pic_left">
<img width="30px" height="auto" src="/descriptions/models/michelin/PilotSport5/40.jpg" class="pic_left">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end