import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(((\\.\\d+)|(0+((e|E)\\d+)?)|(0+\\.\\d*((e|E)-\\d+)?)|((1|1\\.0*)((e|E)-\\d+)?)|(1\\.\\d+((e|E)-[1-9]\\d*)))(\\s+|,\\s*)){3}((\\.\\d+)|(0+((e|E)\\d+)?)|(0+\\.\\d*((e|E)-\\d+)?)|((1|1\\.0*)((e|E)-\\d+)?)|(1\\.\\d+((e|E)-[1-9]\\d*)))$(\n"
+ "# just a way to comment\n"
+ "# The ^$ anchors are there because xml always assumes them.\n"
+ "# They are required here for proper testing.\n"
+ ")*";
final String string = "1 1 1 1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}