$re = '/^(((\.\d+)|(0+((e|E)\d+)?)|(0+\.\d*((e|E)-\d+)?)|((1|1\.0*)((e|E)-\d+)?)|(1\.\d+((e|E)-[1-9]\d*)))(\s+|,\s*)){3}((\.\d+)|(0+((e|E)\d+)?)|(0+\.\d*((e|E)-\d+)?)|((1|1\.0*)((e|E)-\d+)?)|(1\.\d+((e|E)-[1-9]\d*)))$(
# just a way to comment
# The ^$ anchors are there because xml always assumes them.
# They are required here for proper testing.
)*/m';
$str = '1 1 1 1';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);