#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)lines?(?:\s+items?)?\s*\d+(?:\.\d+)?(?:\s*(?:,|and)\s*\d+(?:\.\d+)?)*"
Local $sString = "Line 145" & @CRLF & _
"Line3544354" & @CRLF & _
"Lines 10,12" & @CRLF & _
"Line items 45,10,26" & @CRLF & _
"Lines 10 and 45" & @CRLF & _
"" & @CRLF & _
"Lines 10.5666,12.566" & @CRLF & _
"Line 96.1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")