import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)lines?(?:\\s+items?)?\\s*\\d+(?:\\.\\d+)?(?:\\s*(?:,|and)\\s*\\d+(?:\\.\\d+)?)*";
final String string = "Line 145\n"
+ "Line3544354\n"
+ "Lines 10,12\n"
+ "Line items 45,10,26\n"
+ "Lines 10 and 45\n\n"
+ "Lines 10.5666,12.566\n"
+ "Line 96.1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}