use strict;
my $str = 'https://book.ru/a/5b011c5e0bd5c0582eba2cd9462b05b8/1587531219/38904/1/01.mp3
https://s1.book.ru/a/5b011c5e0bd5c0582eba2cd9462b05b8/1587531219/38904/1/02.mp3
https://books.site/38904/1/01.mp3
https://books.site/38904/1/02.mp3';
my $regex = qr~(https?://)[^/]+/\w/\w{32}/\d+/~mp;
my $subst = '$1books.site/';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";