package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\S+)`)
var str = `abc 123 tr
abd1 124 tr
abce 126 af
abe 128 nm`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}