// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?<myField>[^\s]+)\s*").unwrap();
let string = "T11345DDF ERROR
T11345SSDF Volume C
123455-25335535-55454545-5656566-45655-36565656-6656-488656 TPM
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}