#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\* LIST \((?<Markers>.*)\) \"\/\" (?<folder>.*?)$"
Local $sString = "* LIST (\HasChildren) "/" INBOX/Arkabit" & @CRLF & _
"* LIST (\HasNoChildren) "/" "INBOX/Arkabit/Flora (SAP)"" & @CRLF & _
"* LIST (\HasNoChildren) "/" INBOX/BRW" & @CRLF & _
"* LIST (\HasNoChildren) "/" INBOX/Chiptronics" & @CRLF & _
"* LIST (\HasNoChildren) "/" INBOX/CRMB1.COM" & @CRLF & _
"* LIST (\Marked \HasChildren) "/" INBOX/CVA" & @CRLF & _
"* LIST (\HasNoChildren) "/" INBOX/CVA/Contabilista" & @CRLF & _
"* LIST (\HasNoChildren) "/" INBOX/CVA/Maxflex" & @CRLF & _
"* LIST (\HasNoChildren) "/" INBOX/Decorlux" & @CRLF & _
"* LIST (\HasNoChildren) "/" INBOX/Fabiano" & @CRLF & _
"* LIST (\HasNoChildren) "/" INBOX/Fabielle" & @CRLF & _
"* LIST (\HasNoChildren) "/" INBOX/Gamma" & @CRLF & _
"* LIST (\HasNoChildren) "/" INBOX/Integrate" & @CRLF & _
"* LIST (\HasNoChildren) "/" INBOX/Kelli" & @CRLF & _
"* LIST (\HasNoChildren) "/" INBOX/Laborclin" & @CRLF & _
"* LIST (\HasNoChildren) "/" INBOX/Macrosul" & @CRLF & _
"* LIST (\HasChildren) "/" INBOX/MadeiraMadeira" & @CRLF & _
"* LIST (\HasNoChildren) "/" INBOX/MadeiraMadeira/BRW" & @CRLF & _
"* LIST (\HasNoChildren) "/" INBOX/MadeiraMadeira/Eglo" & @CRLF & _
"* LIST (\HasNoChildren) "/" "INBOX/MadeiraMadeira/Full Fit"" & @CRLF & _
"* LIST (\HasNoChildren) "/" "INBOX/MadeiraMadeira/Glass Mosaic"" & @CRLF & _
"* LIST (\Marked \HasNoChildren) "/" INBOX/MadeiraMadeira/Luciin" & @CRLF & _
"* LIST (\HasNoChildren) "/" INBOX/MadeiraMadeira/Rojemac" & @CRLF & _
"* LIST (\HasNoChildren) "/" "INBOX/Mercado do Alarme"" & @CRLF & _
"* LIST (\Marked \HasChildren) "/" INBOX/Stuff" & @CRLF & _
"* LIST (\HasNoChildren) "/" INBOX/Stuff/Importado" & @CRLF & _
"* LIST (\Marked \HasNoChildren) "/" INBOX/Stuff/Ita&APo-" & @CRLF & _
"* LIST (\Marked \HasNoChildren) "/" INBOX/Stuff/Literal" & @CRLF & _
"* LIST (\HasChildren) "/" INBOX/Stuff/News" & @CRLF & _
"* LIST (\HasNoChildren) "/" INBOX/Stuff/News/Linkedin" & @CRLF & _
"* LIST (\HasNoChildren) "/" INBOX/Stuff/News/Microsoft" & @CRLF & _
"* LIST (\HasNoChildren) "/" INBOX/Stuff/News/SAP" & @CRLF & _
"* LIST (\Marked \HasNoChildren) "/" INBOX/Stuff/Postman" & @CRLF & _
"* LIST (\HasChildren) "/" INBOX/Stuff/PrimaERP" & @CRLF & _
"* LIST (\HasNoChildren) "/" INBOX/Stuff/PrimaERP/Faturas" & @CRLF & _
"* LIST (\Marked \HasNoChildren) "/" INBOX/Stuff/VSOnline" & @CRLF & _
"* LIST (\HasNoChildren) "/" "INBOX/Suporte | CRMSAP"" & @CRLF & _
"* LIST (\HasNoChildren) "/" INBOX/Umbler" & @CRLF & _
"$ OK LIST completed." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")