using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\n ]*((<((([a-zA-Z]+)( +(\w|\w+-+\w*)+ *= *(( *(\w|\w+-+\w*)+ *)|(("") *.+ *(""))|((') *.+ *('))|(\\"" *.+ *\\"")|(\\' *.+ *\\')))* *((\/)|(>([ \n]|.)*<\/[a-zA-Z]+)))|(!--([ \n]|.)*--))>)([\n ]*<((([a-zA-Z]+)( +(\w|\w+-+\w*)+ *= *(( *(\w|\w+-+\w*)+ *)|(("") *.+ *(""))|((') *.+ *('))|(\\"" *.+ *\\"")|(\\' *.+ *\\')))* *((\/)|(>([ \n]|.)*<\/[a-zA-Z]+)))|(!--([ \n]|.)*--))>)*)[\n ]*$)";
string substitution = @"";
string input = @"<div attr1=""value""></div>
<!-- this is a HTML comment -->";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}