# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([\n ]*((<((([a-zA-Z]+)( +(\w|\w+-+\w*)+ *= *(( *(\w|\w+-+\w*)+ *)|((\") *.+ *(\"))|((') *.+ *('))|(\\\" *.+ *\\\")|(\\' *.+ *\\')))* *((\/)|(>([ \n]|.)*<\/[a-zA-Z]+)))|(!--([ \n]|.)*--))>)([\n ]*<((([a-zA-Z]+)( +(\w|\w+-+\w*)+ *= *(( *(\w|\w+-+\w*)+ *)|((\") *.+ *(\"))|((') *.+ *('))|(\\\" *.+ *\\\")|(\\' *.+ *\\')))* *((\/)|(>([ \n]|.)*<\/[a-zA-Z]+)))|(!--([ \n]|.)*--))>)*)[\n ]*$)"
test_str = ("<div attr1=\"value\"></div>\n"
"<!-- this is a HTML comment -->")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.