const regex = /(select)(.*?)(from)[\\r\\n]*/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(select)(.*?)(from)[\\\\r\\\\n]*', 'gim')
const str = `SELECT\\r\\n money\\r\\nFROM\\r\\n accounts
"SELECT\\r\\n device_id\\r\\nFROM\\r\\n temp.test_sets AS device_infos\\r\\nJOIN (\\r\\n SELECT\\r\\n google_ad_id\\r\\n FROM\\r\\n test*\\r\\n)`;
const subst = `\1 count(*) \2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);