#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)bj-([0-9]{2})_([0-9]{4})[-]*([0-9]{2})?_?([0-9]{4})?([(]([[:alnum:]]{0,4},?)*[)])?"
Local $sString = "bj-11_2008-06_2015(F01,F02,F03,F04)" & @CRLF & _
"bj-11_2008-06_2015(F01)" & @CRLF & _
"bj-11_2008-06_2015(01)" & @CRLF & _
"bj-11_2008-06_2015(3B)" & @CRLF & _
"bj-11_2008-06_2015" & @CRLF & _
"bj-11_2008"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")