package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)bj-([0-9]{2})_([0-9]{4})[-]*([0-9]{2})?_?([0-9]{4})?([(]([[:alnum:]]{0,4},?)*[)])?`)
var str = `bj-11_2008-06_2015(F01,F02,F03,F04)
bj-11_2008-06_2015(F01)
bj-11_2008-06_2015(01)
bj-11_2008-06_2015(3B)
bj-11_2008-06_2015
bj-11_2008`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}