package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([\w\d-!$%^&*()_+|~=`{}\[\]:";'<>?,.\/]+)(.mp4|.avi|.mov)`)
var str = `dvideoimageslide_5563.vi%$%$/&%deo.20190321160326.mp4.1558540973099_html5_api`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}