package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\[\d{2}:\d{2}-\d{2}:\d{2}])`)
var str = `[10:42-23:10]part1[11:30-13:20]part2[4][5]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}