$re = '/(\[\d{2}:\d{2}-\d{2}:\d{2}])/';
$str = '[10:42-23:10]part1[11:30-13:20]part2[4][5]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);