// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\[\d{2}:\d{2}-\d{2}:\d{2}])").unwrap();
let string = "[10:42-23:10]part1[11:30-13:20]part2[4][5]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}