#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(\d+)(?: \1){3,}\b|\b(\d+)(?: \2){2}\b"
Local $sString = "I am 42 42 4 hey yoo" & @CRLF & _
"I am 42 42 42 hey yoo" & @CRLF & _
"I am 42 42 42 4 hey yoo'," & @CRLF & _
"I am 42 42 42 42 hey yoo"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")