$re = '/(\(\s*)[abcd|\d](\s*\)*)$|\d$|\s+[abcd]$|[abcd]\)|\([a-z]+\)$|[\-,.\/]\s*[abcd]$|\(\d{1,}\)$/m';
$str = 'Nguyễn Đức Anhb
Nguyễn Đức Anh/b
Nguyễn Đức Anh (mb)
Nguyễn Đức Anh (hn)
Nguyễn Đức Anh (hsdb)
Nguyễn Đức Anh - b
Nguyễn Đức Anh.b
Nguyễn Đức Anh -b
Nguyễn Đức Anh-b
Nguyễn Đức a
Nguyễn Đức Anh b
Nguyễn Đức Anh (a)
Nguyễn Đức Anh (b)
Nguyễn Đức Anh (a
Nguyễn Đức Anh (b
Nguyễn Đức Anh (b
Nguyễn Đức Anha)
Nguyễn Đức Anh(b)
Nguyễn Đức Anh (a )
Nguyễn Đức Anh ( c)
Nguyễn Đức Anh1
Nguyễn Đức Anh2
Nguyễn Đức Anh 1
Nguyễn Đức Anh 2
Nguyễn Đức Anh (1)
Nguyễn Đức Anh (21)
Nguyễn Đức Anh
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);