// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b[0-9]+\s*k\b").unwrap();
let string = "1) 150 k
2) 150 kilobyte
3) 150 ka
4) 150 k2
5) 150 k)
6) 150 k.
150 k <- beginning of line
... works with other characters (150 k)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}