import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9]{11}).+?(\\s*[0-9].+)";
final String string = "01234567890Alice Stone 3978 Smith st...\n"
+ "01234567890Alice Stone3978 Smith st...";
final String subst = "$1xxxxxxxxxxxxxxxxxxxx$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}