$re = '/(\w+)[:<>]([^,\n]+)/';
$str = 'firstName:Giorgio,
email:giorgio.rossi@libero.it,
dataregistrazione:27/10/2016,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);