// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[\s-]*(?:\d[\s*-]*){4}$").unwrap();
let string = "- 3 --- 1 2---4- -
- 3 --- 12---4- -
- 3 --- 1 2---- -
- 3 --- 1- 2---4- 5-";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}