$re = '/(\S+) (\S*) ?\b(\S+)/';
$str = 'foo it\'s';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);