#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[\+\-]\(+\d+[\*\/]0\)"
Local $sString = "(((7+5)*75)+(3*0))+2 = 902" & @CRLF & _
"((7+5)*75)+(3*0))+2 = 902" & @CRLF & _
"(7+5)*75+(3*0)+2 = 902" & @CRLF & _
"(7+5)*75+3*0+2 = 292"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)