use strict;
my $str = '(((7+5)*75)+(3*0))+2 = 902
((7+5)*75)+(3*0))+2 = 902
(7+5)*75+(3*0)+2 = 902
(7+5)*75+3*0+2 = 292';
my $regex = qr/[\+\-]\(+\d+[\*\/]0\)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";