#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^ETB-2022-\d{1,}"
Local $sString = "ETB-2022-01" & @CRLF & _
"ETB-2022-02" & @CRLF & _
"ETB-2022-03" & @CRLF & _
"E-ETB-2022-01" & @CRLF & _
"E-ETB-2022-02"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")