using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^ETB-2022-\d{1,}";
string input = @"ETB-2022-01
ETB-2022-02
ETB-2022-03
E-ETB-2022-01
E-ETB-2022-02";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}