package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^ETB-2022-\d{1,}`)
var str = `ETB-2022-01
ETB-2022-02
ETB-2022-03
E-ETB-2022-01
E-ETB-2022-02`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}