const regex = /^ETB-2022-\d{1,}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^ETB-2022-\\d{1,}', 'gm')
const str = `ETB-2022-01
ETB-2022-02
ETB-2022-03
E-ETB-2022-01
E-ETB-2022-02`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}