re = /^ETB-2022-\d{1,}/m
str = 'ETB-2022-01
ETB-2022-02
ETB-2022-03
E-ETB-2022-01
E-ETB-2022-02'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end