using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s(?!money$).*";
string substitution = @"";
string input = @"Hello monet";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}