using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=class="").*?(?="">)";
string input = @"<tajweed class=""ham_wasl"">ٱ foo</tajweed>
<tajweed class=""madd"">ٱ bar</tajweed>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}