$re = '/(?<=\d{4}\-\d{2}\-\d{2}|\d{4}.\d{4}|\d{4}.\d{1}.\d{1}.\d{2}|\d{4}.\d{2}.\d{2}).*?(?=\d)/m';
$str = '. FIRST BANK OF WIKI
, 1425 JAMES ST, PO BOX 4000 CHEQUING ACCOUNT STATEMENT
VICTORIA BC V8X 3X4 1-800-555~5555 Page: 1 of 1
JOHN JONES I Sififi3331‘3311 Erma II EEK-111313010: I
1643 DUN DAS ST W APT 27 2003-10-09 to 200341-08 00005-
TORONTO ON M6K 1V2 123-4567
I sue II 1% 1::ng “W II um II I
2003-10-08 Previous balance 0.55 I
2003-10-14 Payroll Deposit - HOTEL 694.81 695.36
2003-10-14 Web Bill Payment - MASTERCARD 9685 200.00 495.36
2003—1046 ATM Withdrawal - INTERAC 3990 21 .25 474.11 .
2003-10-16 Fees - lnterac 1 .50 472.61 I
2003-10-20 Interac Purchase - ELECTRONICS 1975 2.99 469.62 .
2003-10-21 Web Bill Payment - AMEX 3314 300.00 169.62
2003-1 0-22 ATM Withdrawal - FIRST BANK 0064 100.00 69.62 .
2003-10-23 lnterac Purchase - SUPERMARKET 1 559 29.08 40.54 I
2003-10-24 Interac Refund - ELECTRONICS 1975 2.99 43.53
2003-10-27 Telephone Bill Payment — VISA 2475 6.77 36.76 I
2003-1328 Payroll Deposit - HOTEL 694.81 731.57 .
2003-10~30 Web Funds Transfer - From SAVINGS 2620 50.00 781.57 I
2003-11-03 Pre-Auth. Payment - INSURANCE 33.55 748.02 .
2003-11-03 Cheque No. - 409 1 00.00 648.02
2003-11-06 Mortgage Payment 710.49 -62.47 .
2003-11-07 Fees - Overdraft 5.00 -67.47 I
2003-11-08 Fees - Monthly 5.00 -72.47
*** Totals m 1 ,515.63 1,442.61 I';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);