# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(..\..).+\n(?<!not )undefined.+"
test_str = ("datetime,n_dayAVG,n_nightAVG\n"
"2021-02-13T23:00:00Z,0,38.75689941512687\n"
"2021-02-14T06:00:00Z,42.928258741926456,39.480753102759024\n"
"2021-02-15T06:00:00Z,43.75857849703471,39.9099923987705\n"
"2021-02-16T06:00:00Z,40.64147976311876,39.62856460216651\n"
"2021-02-17T06:00:00Z,43.01380733014874,39.58893298143956\n"
"undefined,0,0")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.