#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\[row]\r?\n([^]*?)\r?\n\[rowEnd]"
Local $sString = "[row]" & @CRLF & _
"Row text1" & @CRLF & _
"[rowEnd]" & @CRLF & _
"" & @CRLF & _
"[row]" & @CRLF & _
"Row text2" & @CRLF & _
"test" & @CRLF & _
"[rowEnd]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")