using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\[row]\r?\n([^]*?)\r?\n\[rowEnd]";
string input = @"[row]
Row text1
[rowEnd]
[row]
Row text2
test
[rowEnd]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}