const regex = /^\[row]\r?\n([^]*?)\r?\n\[rowEnd]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\[row]\\r?\\n([^]*?)\\r?\\n\\[rowEnd]', 'gm')
const str = `[row]
Row text1
[rowEnd]
[row]
Row text2
test
[rowEnd]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}