$re = '/^\\\\m\s+((?:\w+\s+)*\w+):\s*(.*)/m';
$str = '\\m Character name: message
\\m Sample: message';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);