using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(?<code>[A-Z_]{10})?_?(?<seq>[0-9]{2})?\.[A-Z]{3}$";
string input = @"ABLU_TE_BO_03.jpg";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}