$re = '/-.*$/m';
$str = 'Knight Frank - Mayfair branch
Savills - Knightsbridge branch
Sotheby\'s
Hamptons International';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;